Mojave - Audio not working after sleep

This issue has been created since 2021-06-03.

I downgraded from Big Sur to Mojave.
Audio works fine on first boot, but not working after sleep.
This only happens on Mojave, not Big Sur.
How can I fix this?

CLAY-BIOS wrote this answer on 2021-06-04

I downgraded from Big Sur to Mojave.
Audio works fine on first boot, but not working after sleep.
This only happens on Mojave, not Big Sur.
How can I fix this?

The bin Directory in Big Sur and Catalina is / usr/local/bin/
While the bin directory in Mojave is / usr/bin
In theory, you just need to modify the ALCPlugFix--> install.sh file:
BIN_PATH= / usr/local/bin/ is modified to BIN_PATH= / usr/bin/

mybabysexy wrote this answer on 2021-06-04

ok I'll try

CLAY-BIOS wrote this answer on 2021-06-04

ok I'll try

ALCPlugFix -> CLAY.win.ALCPlugFix.plist
The path in the file also needs to be modified

mybabysexy wrote this answer on 2021-06-04

still no sound after sleep
image

mybabysexy wrote this answer on 2021-06-04
CLAY-BIOS wrote this answer on 2021-06-04

still no sound after sleep
image

No sound from the external player, or no sound from the headphones?

mybabysexy wrote this answer on 2021-06-04

still no sound after sleep
image

No sound from the external player, or no sound from the headphones?

No sound from internal speaker, 3.5mm jack loud noise

CLAY-BIOS wrote this answer on 2021-06-04

still no sound after sleep
image

No sound from the external player, or no sound from the headphones?

No sound from internal speaker, 3.5mm jack loud noise

The ALCPlugFix script is used to fix the 3.5mm noise.
As for the speakers having no sound, I ' m not sure what is wrong.
I will install the Mojave to test it.

CLAY-BIOS wrote this answer on 2021-06-06

@mybabysexy
I tested it on Mojave, but I didn't find the problem you said. Audio works normally.

mybabysexy wrote this answer on 2021-06-07

can I dump my configurations or something to help you check?

CLAY-BIOS wrote this answer on 2021-06-07

can I dump my configurations or something to help you check?

of course can.

mybabysexy wrote this answer on 2021-06-07

what files do you need?

CLAY-BIOS wrote this answer on 2021-06-07

what files do you need?

1.Execute at the terminal:log show --last boot | grep -Ei "Wake"
2.Are you using Intel-WiFi? If so, try disabling it in the BIOS.
3.Execute at the terminal:log show --last boot | grep -Ei "ACPI"
I need to print the information

mybabysexy wrote this answer on 2021-06-07

what files do you need?

1.Execute at the terminal:log show --last boot | grep -Ei "Wake"
2.Are you using Intel-WiFi? If so, try disabling it in the BIOS.
3.Execute at the terminal:log show --last boot | grep -Ei "ACPI"
I need to print the information

acpi.after-sleep.log
acpi.before-sleep.log
wake.after-sleep.log
wake.before-sleep.log

CLAY-BIOS wrote this answer on 2021-06-08

what files do you need?

1.Execute at the terminal:log show --last boot | grep -Ei "Wake"
2.Are you using Intel-WiFi? If so, try disabling it in the BIOS.
3.Execute at the terminal:log show --last boot | grep -Ei "ACPI"
I need to print the information

acpi.after-sleep.log
acpi.before-sleep.log
wake.after-sleep.log
wake.before-sleep.log

Sorry, I didn't find anything wrong.
Everything works fine in my tests.
Maybe the reinstallation can be resolved.

mybabysexy wrote this answer on 2021-06-08

what files do you need?

1.Execute at the terminal:log show --last boot | grep -Ei "Wake"
2.Are you using Intel-WiFi? If so, try disabling it in the BIOS.
3.Execute at the terminal:log show --last boot | grep -Ei "ACPI"
I need to print the information

acpi.after-sleep.log
acpi.before-sleep.log
wake.after-sleep.log
wake.before-sleep.log

Sorry, I didn't find anything wrong.
Everything works fine in my tests.
Maybe the reinstallation can be resolved.

I tried to reinstall yesterday but audio didn't work after sleep. I'll try Catalina instead

mybabysexy wrote this answer on 2021-06-16

Hi, I installed Catalina today but audio isn't recognized, how can I fix this?
Hackintool shows below
image

CLAY-BIOS wrote this answer on 2021-06-16

Hi, I installed Catalina today but audio isn't recognized, how can I fix this?
Hackintool shows below
image

Select reset nvram on the boot interface to clear nvram.

CLAY-BIOS wrote this answer on 2021-06-17

Hi, I installed Catalina today but audio isn't recognized, how can I fix this?
Hackintool shows below
image

Has the problem been solved?

mybabysexy wrote this answer on 2021-06-17

Cleared NVRAM and audio detected! Thanks

More Details About Repo
Owner Name CLAY-BIOS
Repo Name Lenovo-ThinkPad-T450s-Hackintosh-OpenCore
Full Name CLAY-BIOS/Lenovo-ThinkPad-T450s-Hackintosh-OpenCore
Language ASL
Created Date 2020-07-30
Updated Date 2022-09-02
Star Count 231
Watcher Count 25
Fork Count 48
Issue Count 24

YOU MAY BE INTERESTED

Issue Title Created Date Comment Count Updated Date
make kat under Debian 11 (solved) 4 2022-07-24 2022-08-08
V3.5.0 在Android 7.1.2 上 调用OkHttps.async().setOnResBean崩溃 2 2022-04-29 2022-09-05
Can we preload canvas with an existing svg file? 0 2021-11-21 2022-07-25
Improvements and additions to modelisation and evaluation elements 1 2021-09-07 2022-08-26
generate noise image on complete image 0 2021-08-11 2022-08-17
Problem with coffeescript adder 2 2022-01-29 2022-09-15
Elementwise reductions shouldn't return the same value in all DOFs of the element 6 2021-11-03 2021-12-26
Github Recon Upgradation 5 2022-08-27 2022-09-18
NetHook2 doesn't do anything 9 2020-08-10 2022-09-07
missing translation for string "Start of vacation" in admin 1.9.12 Auto-reply form 0 2022-02-04 2022-09-13
`fleetctl updates add` command fails with `Error: make snapshot: invalid character ...` 0 2022-08-23 2022-08-23
[PW-6590] placeOrder mutation in GraphQl not working 2 2022-04-22 2022-09-18
GM_info and script update check 4 2014-07-01 2022-09-16
Names with escaped brackets do not match 1 2021-04-02 2022-07-10
Add license checking github action 1 2021-04-11 2022-07-10
Add license automated check in Travis 1 2020-04-22 2022-08-11
Error in grafana Windows: Modified signature 2 2021-02-05 2022-09-06
Earth Day celebration deadline discrepancy 0 2022-02-06 2022-08-30
Cannot use computed properties with a function when doing SSR 0 2021-06-23 2022-09-06
Can't install on node 15 4 2021-04-16 2022-08-16
Using Consumer API in gatling kafka plugin 7 2021-05-17 2022-07-29
Clear console on every build 8 2021-09-27 2022-09-14
API returns "Device is too old to satisfy required version range" 1 2021-06-18 2022-08-01
DefaultWebMvcTagsProvider Code Flow. 3 2021-08-31 2022-09-28
.then is Not a Function 1 2020-04-29 2022-09-05
Data.Set.Monad instance 2 2019-11-02 2022-09-16
Attachment sent to a M365 group is not shown to the recepient. 1 2022-06-09 2022-08-21
Order Cancelled after payment has been taken 0 2021-01-18 2022-09-28
BlobInput example includes QueueTrigger 1 2022-04-11 2022-08-22
Razer Nari Ultimate 1 2021-10-25 2022-01-16
faq links to unmaintained matrix-python-sdk 0 2021-07-27 2022-09-26
Issue with default digest md5 2 2022-08-18 2022-09-07
Missing documentation about the conventions around colon & equals signs in arguments? 4 2021-10-10 2022-08-28
[Feature Request]: Create panel windows (NSPanel) on macOS 5 2021-10-21 2022-08-17
False positive: SlevomatCodingStandard.Namespaces.UnusedUses.MismatchingCaseSensitivity (with searchAnnotations) 4 2021-08-07 2022-09-27
index out of range 1 2017-11-29 2022-01-06
Support affine transformations with negative translations 1 2022-03-14 2022-09-07
Definition and Settings of Beam Size 8 2021-02-02 2022-09-21
View server logs? 1 2020-01-11 2022-01-21
Radzen Sidebar Toggle broken in WebAssembly when starting collapsed 5 2022-02-03 2022-08-29
Schema sequence mismatch on fresh install 3 2017-05-17 2022-08-04
Netbeans IDE pluggin issue 1 2020-10-23 2022-09-28
pipelines: Warn or Fail Fast if a Pipeline run is invoked with local runner 0 2022-09-06 2022-09-14
Failed to deploy to production 0 2021-09-20 2022-09-28
Failed to deploy to production 0 2021-09-20 2022-08-29
How hash could be converted to Uint8Array? 1 2021-07-28 2022-09-21
[Bug]: Navigating directly to hex zooms out map 0 2021-10-06 2022-09-21
Why is the vertex pose changed when the pose is added to optimizer in sba_demo.cpp? 2 2022-08-06 2022-09-19
when I compile with hdfs ,its error 1 2022-07-11 2022-09-14